Skip to main content

Download and Compatibility

View the Release Notes for a description of the latest features and improvements.

Sonatype Application

Version

Download

Sonatype IQ Server & CLI

nexus-iq-server-latest.tar.gz (ASC, SHA1)

nexus-iq-server-latest.zip(ASC,SHA1)

The command-line scanner (CLI) is included in the bundle.

CLI - Cross-platform (Java)

nexus-iq-cli-latest.jar (ASC, SHA1)

Requires the Java Virtual Machine

CLI - Windows

Requires the Visual C++ Runtime. This is included in the zip, or it can be installed and maintained by Windows Update.

CLI - Mac OSX

This Mac pkg installer places files in the /usr/local/bin directory and has been tested on both M1 and Intel chipsets.

Alternatively, you can use Homebrew

CLI - Linux

Alternative install: Deb and RPM

Tested on Centos 7.1+, RHEL 7.3+, Debian 8+, Ubuntu 14.04+

Sonatype Repository Firewall

Sonatype Repository Firewall documentation

Sonatype Nexus Repository

3.0 or greater

Found in the Repository help documentation

Sonatype Repository Firewall for Artifactory

2.4.8

nexus-iq-artifactory-plugin-2.4.8.zip (ASC, SHA1)

Repository Firewall for Artifactory plugin documentation

CI Integrations

Maven

This plugin is automatically downloaded when invoked through Maven

Release Notes - Sonatype CLM for Maven

Bamboo

The release notes are available on the Atlassian Marketplace

Jenkins

Installation through the Jenkins UI

Installation through the Jenkins Plugin Manager

The release notes are available from the project's changelog.

Hudson/Jenkins.1

2.21.5

This plugin is deprecated and not supported

Azure DevOps

The installation instructions and release notes are available on the Visual Studio Marketplace

IDE Integrations

Eclipse

The release notes are available on the Eclipse Marketplace

Eclipse Update Site: https://download.sonatype.com/clm/eclipse/releases

The update site is not directly browsable, enter it into the list of update sites in Eclipse under "Help-> Preferences -> Install/Update -> Available Software Update Sites.

The plugin zip can be installed into Eclipse by using "Help -> Install New Software ->Add... -> Archive...".

  • IBM Rational Application Developer (RAD) is not tested but should work.

  • The plugin requires Eclipse 4.13 and greater, RAD versions based on Eclipse older than this may not work.

IDEA

The release notes are available on the JetBrains Marketplace

VS Code

The "Sonatype for VS Code" extension is installable from within VS Code using the Extensions tool window.

The release notes are available on the Visual Studio Marketplace

Visual Studio 2022

The "Sonatype Lifecycle Plugin for Visual Studio" extension is installable from within Visual Studio using the Extensions and Updates dialog box.

The release notes are available on the Visual Studio Marketplace

Visual Studio 2019

This plugin is deprecated and not supported

Reporting Integrations

Sonatype for Jira Data Center

The release notes are available on the Atlassian Marketplace

SonarQube

This plugin is deprecated and not supported

Compatibility with Integrations

Sonatype encourages using an IQ Server release no older than six months. Contact the Support Team for assistance updating older versions of IQ Server or any associated integration.

Sonatype Nexus Repository 2 compatibility with IQ Server

Nexus Repository 2

IQ Server

2.12 and higher

All versions

Sonatype Nexus Repository 3 compatibility with IQ Server

Review the Repository Firewall documentation for details on feature compatibility between the IQ server and the Nexus Repository.

Nexus Repository 3

IQ Server

3.30 and higher

106 and higher

3.6 through 3.29.2*

1.35 and higher

3.5**

1.33 and higher

*Nexus Repository 3.8 is the first version that fully supports Repository Firewall with High Availability Clustering (HA-C).

**Nexus Repository 3.5 is the first version that has a Repository Firewall properly supported for all repository formats (including NuGet). Previous versions have known issues and are not listed on this page.

Sonatype Lifecycle for Nexus Repository Pro

Sonatype Lifecycle for Nexus Repository Pro does not require the installation of any specialized components. We recommend staying up to date on the latest version of both products.

Sonatype Lifecycle CLI

Java 11 is supported as of release 89. Use Java 8 for earlier versions.

Sonatype Lifecycle for Bamboo

Plugin Version

IQ Server Version

Bamboo Version

Java Runtime

2.42.0-01

70 and higher

8.2.0 through 9.5.1

JDK 11

2.0 through 2.41.1-01

70 and higher

6.8 through 9.0

JDK 8, JDK 11 (Bamboo 8+)

1.14 through 2.0

70 and higher

5.10 through 7.2

JDK 8

1.13

69 and higher

5.10 through 7.2

JDK 8

1.9 through 1.12.1

50and higher

5.10 through 7.2

JDK 8

1.8

1.45 and higher

5.10 through 7.2

JDK 8

1.1 through 1.7

All versions

5.10 through 7.2

JDK 8

Sonatype Platform Plugin for Jenkins

Required Jenkins plugins:

  • Pipeline: Step API 2.22 or newer

  • Credentials 2.3.14.1 or newer

  • Plain Credentials 1.3 or newer

  • Structs 1.20 or newer

For plugin 3.16.449.v50228c7ca_222 version and higher:

  • Pipeline: API 2.41 or newer

Updated to the required plugins may require newer versions of Jenkins.

Plugin Version

IQ Server Version

Jenkins

Java Runtime

3.19.0 and higher

144 and higher

2.361.1 (LTS) or higher

JDK 11, 17

3.16.514 through 3.18.1

144 and higher

2.346.3 (LTS) or higher

JDK 8, 11, 17

3.16.444 through 3.16.510

144 and higher

2.303.3 (LTS) or higher

JDK 8, 11

3.6.20190722-122200.83d1447 to 3.15.438

69 and higher

2.249.1 (LTS) or higher

JDK 8, 11

3.3.20180830-142202.6bdf614 to 3.5.20190425-152158.c63841b

50 and higher

2.249.1 (LTS) or higher

JDK 8, 11

3.0.20180425-130011.728733c to 3.3.20180801-112343.4970c8a

47 and 48

2.249.1 (LTS) or higher

JDK 8, 11

1.1 to 3.0.20180214-134325.e135900

26 - 46

2.249.1 (LTS) or higher

JDK 8

IQ Azure DevOps Extension

The organization ID parameter requires at least version 1.5.0 of the plugin and IQ Server 143 or higher

IQ Azure DevOps Extension Version

IQ Server Version

Supported Environment

Java Runtime

1.2.0 and higher

66 and higher

Azure DevOps Services (hosted)

Azure DevOps Server 2019

JDK 8, JDK 11

1.0.0 through 1.1.0

66 and higher

Azure DevOps Services (hosted)

JDK 8, JDK 11

Sonatype Lifecycle for Eclipse

The Eclipse plugin will use the system browser. The recommended browsers are Chrome, Firefox, or Microsoft Edge.

For the Linux environment, the libwebkit that matches the Eclipse GTK version is required (e.g. libwebkitgtk-3.0-0).

Sonatype Lifecycle for Eclipse Version

IQ Server Version

Eclipse Version

M2e Version

Java Runtime

2.8 through 2.16

66 and higher

4.13 (2019-09) - 4.24 (2022-06)

1.13 through 1.18

JDK 8+

3.0 and higher

66 and higher

4.25 (2022-09) and higher

2.0+

JDK 11+

Sonatype CLM for Maven Plugin

Sonatype CLM for Maven requires Maven 3.3.1 or newer in order to run with Java 16 or newer.

The organization ID parameter requires at least version 2.33.0 of the plugin and IQ Server 143 or higher

Plugin Version

IQ Server Version

Maven Version

Java Runtime

2.32.0 and higher

69 and higher

3.2.3 through 3.9.1

JDK 8+

2.13.0 through 2.31.0

69 and higher

2.1 through 3.6.3

JDK 8+

2.9.x through 2.12.1

50 and higher

2.1 through 3.6.3

JDK 7, JDK 8

2.8.1

45 and higher

2.1 through 3.6.3

JDK 7, JDK 8

2.3 through 2.8

All versions

2.1 through 3.6.3

JDK 7, JDK 8

Sonatype Lifecycle for IDEA

Plugin Version

Development Environment

Version

IQ Server Version

Java Runtime

4.11 or later

IDEA Ultimate, IDEA Community, WebStorm, PyCharm Professional, PyCharm Community

2023.1 or higher

129 or higher

JBRSDK 17

4.4 - 4.10

IDEA Ultimate, IDEA Community, WebStorm,

PyCharm Professional, PyCharm Community

2022.1 or higher

129 or higher

JBRSDK 11, JBRSDK 17

4.2 - 4.3

IDEA Ultimate, IDEA Community, WebStorm,

PyCharm Professional, PyCharm Community

2021.2 through 2021.3.x

129 or higher

JBRSDK 11

4.1

IDEA Ultimate, IDEA Community, WebStorm,

PyCharm Professional, PyCharm Community

2020.3 through 2021.3.x

129 or higher

JBRSDK 11

4.0

IDEA Ultimate, IDEA Community, WebStorm

2020.3 through 2021.3.x

67 or higher

JBRSDK 11

3.x

IDEA Ultimate, IDEA Community, WebStorm

2020.2.x

67 or higher

Oracle JDK 8, JBRSDK 8, JBRSDK 11

2.x

IDEA Ultimate, IDEA Community

2016.2 through 2020.1.x

67 or higher

Oracle JDK 8, JBRSDK 8, JBRSDK 11

1.x

IDEA Ultimate, IDEA Community

14.1.x through 15.0.3

66 or higher

Oracle JDK 8, JBRSDK 8

Sonatype for VS Code

Plugin Version

IQ Server Version

VS Code Version

1.0.0 and higher

129 and higher

1.85.0 and higher

Sonatype Lifecycle for Visual Studio 2022

Plugin Version

IQ Server Version

VS Code Version

1.0. and higher

129 and higher

17.6.x and higher

Sonatype Lifecycle for Visual Studio 2019

Plugin Version

IQ Server Version

Visual Studio

Microsoft .NET

1.0 and higher

32 and higher

Community 2015-2019

Professional 2015-2019

Enterprise 2015-2019

4.5 and higher

Firewall for Artifactory

Plugin Version

IQ Server Version

Artifactory Version

2.2 and higher

119 and higher

Tested on multi-node clusters

Tested on JFrog Artifactory Enterprise 7.2.6

1.* to 2.0

Updating requires IQ 119 and data migration

Sonatype Lifecycle for Jira

Plugin Version

IQ Server Version

Jira Version

1.x

98 and higher

Compatible with Jira Server and Jira Data Center.

Sonatype Lifecycle for SCM

Feature \ SCM

Azure DevOps

Bitbucket Cloud

Bitbucket Server

GitHub

GitLab

Automated Commit Feedback

IQ 122

IQ 90

IQ 90

IQ 67

IQ 71

Automated Pull Requests

IQ 122

IQ 90

IQ 90

IQ 79

IQ 97

Pull Request Commenting

IQ 122

IQ 95

IQ 88

IQ 98

Pull Request Line Commenting

IQ 95

IQ 95

IQ 99

Bitbucket Code Insights

N/A

IQ 95

N/A

N/A

Sonatype Lifecycle Fortify SSC Integration

Sonatype Lifecycle Fortify SSC Integration

IQ Server Version

Fortify Software Security Center

1.0 and higher

98 and higher

List of supported versions on the Microfocus Marketplace.