Security Compatibility

Before you upgrade from version 2 to version 3 review the differences in security settings along the upgrade path. Known changes may affect privileges, roles and repository targets.

Version 2 Roles

Roles upgraded from version 2 are assigned a Role ID that starts with nx2- in Nexus Repository Manager 3. Role descriptions created during the upgrade process have the word legacy in their description.

Version 2 Repository Targets and Target Privileges

Repository targets from version 2 are converted to Content Selectors in version 3. Repository targets were based on regular expressions, and are automatically converted to CSEL (Content Selector Expression Language), a performant subset of JEXL.