Upgrade Compatibility - Nexus Repository 2 to 3

Requirement: Always Use Latest Versions

Sonatype always recommends having the latest version 2 upgrading to the latest version 3 (as well as IQ Server for applicable users).  Latest versions have the latest bug fixes, especially important for the upgrade process and compatibility with new features of Nexus Repository 3.

Upgrading to an older Nexus Repository 3 then subsequently updating to the latest Nexus Repository 3 is not equivalent, as it will hit old upgrade bugs.

Requirement: Always Use Same License

When upgrading from Nexus Repository 2 to 3, both versions must have the same licensing setup

The same license file can be used in Nexus Repository 2 and Nexus Repository 3 or a license can always be applied at a later time.

Licensing: Valid Upgrade PathLicensing: Unsupported Upgrade Path

Nexus Repository OSS 2 → Nexus Repository OSS 3

Nexus Repository Pro 2 → Nexus Repository Pro 3

Nexus Repository OSS 2 → Nexus Repository Pro 3

Nexus Repository Pro 2 → Nexus Repository OSS 3