Download and Compatibility

You should have already received an email containing the necessary information to unlock all the Nexus IQ Server features you have purchased. If you have not received this, please contact your Sales executive directly, or send an email to support@sonatype.com.

Depending on your purchase, you may need to install additional tools such as the Bamboo or Jenkins plugin. No matter what was purchased, you will need to download and install Nexus IQ Server first.

If you would like to see a description of the latest features, as well as those for a specific release, view our Release Notes

Starting with the 1.17 release, Sonatype CLM was renamed to Nexus IQ Server. You may still occasionally see Sonatype CLM in the product or documentation.

Latest Versions

Sonatype Application Latest Version Download
IQ Server & CLI 1.49.0

Starting in 1.45, Nexus IQ Server uses a more effective and condensed format to store policy violation data. Depending on the database size of your installation and the hardware you use, upgrading your database to this new format can take notable time (up to hours in the worst case scenarios). You should review the upgrade procedure detailed in  Upgrading the IQ Server to Version 1.45 .

nexus-iq-server-latest.tar.gz (ASCMD5SHA1)

nexus-iq-server-latest.zip (ASCMD5SHA1)

This bundle already contains the CLI tool for convenience.

Repository Manager 2

2.x

Please see Download Repository Manager 2

Repository Manager 3 3.x Please see Download Repository Manager 3
Bamboo 1.8.1 nexus-iq-bamboo-plugin-1.8.1-03.obr  ( ASCMD5SHA1 )
Jenkins 3.x

Available to update through the Jenkins Update Center

Hudson/Jenkins 1 2.21.0

This plugin is deprecated and is no longer receiving updates. We suggest that you uninstall this plugin and then install the Jenkins 3.x plugin; however, there is no automated process to migrate jobs between plugins.

nexus-iq-jenkins-plugin-2.21.0-01.hpi (ASCMD5SHA1)

Eclipse 2.13.0

Eclipse Update Site: https://download.sonatype.com/clm/eclipse/releases

The link above is not directly browsable, enter it into the list of update sites in Eclipse under "Help - Preferences - Install/Update - Available Software Update Sites.

If you need an offline copy of this site, see here for mirroring instructions.

IBM Rational Application Developer (RAD) is not tested, but should work. Note that the plugin requires Eclipse 3.6 and greater, RAD versions based on Eclipse older than this will not work.

SonarQube 1.2.0 sonatype-clm-sonarqube-1.2.0-02.jar (ASCMD5SHA1)
CLI 1.49.0 nexus-iq-cli-1.49.0-01.jar  (ASCMD5SHA1)
Maven 2.8.1 This plugin is automatically downloaded when invoked.
IDEA 2.0.0 nexus-iq-idea-plugin-2.0.0-01.zip (ASCMD5SHA1)
Visual Studio 1.0 The "Nexus IQ for Visual Studio" extension is installable from within Visual Studio using the Extensions and Updates dialog box. The extension may also be downloaded from the Visual Studio Marketplace.

Clouds and Containers

Sonatype Nexus Repository Manager and IQ Server are offered via various cloud services and container formats. More information is available in the Integration space under Cloud Deployments.

Compatibility

Sonatype encourages using the most current IQ Server release and not trailing behind more than six months. If you are using an older version of Nexus IQ Server, or any of the associated integrations, and wish to upgrade to the latest version, please contact our Support Team.

Some versions of Nexus IQ Server (1.26 and above) are not fully compatible with old integrations. In cases where reverse proxy authentication is used, communication failures could occur between old integrations and the IQ Server. Integrations should be updated to the latest version when using reverse proxy authentication. For more information, please see our documentation on Upgrading the IQ Server.

Compatibility of IQ Server with versions of our associated integrations is listed below:

IQ compatibility with Nexus Repository Manager 2

IQ Server Version Repo 2 Version Compatibility
All versions 2.12 and higher

IQ compatibility with Nexus Repository Manager 3

IQ Server Version Repo 3 Version Compatibility
1.35 and higher 3.6 and higher*
1.34 and lower 3.6 and higher*
1.33 and higher 3.5**
1.32 and lower 3.5**


*Nexus Repository Manager 3.8 is the first version that fully supports Firewall with High Availability Clustering (HA-C).

**Nexus Repository Manager 3.5 is the first version that has Firewall properly supported for all repository formats (including NuGet). Previous versions have known issues and are not listed on this page.

IQ compatibility with Bamboo

IQ Server Version Bamboo Version Compatibility
All versions 1.1 through 1.7
1.45 and higher 1.8
1.44 and lower 1.8

IQ compatibility with Jenkins

IQ Server Version Jenkins Plugin Version Compatibility
1.45 and higher 3.1.x and higher

1.26 through 1.44 1.1 through 3.0.x
1.25 and lower

IQ compatibility with Hudson/Jenkins 1

This plugin is deprecated and is no longer receiving updates. We suggest that you uninstall this plugin and then install the Jenkins 3.x plugin; however, there is no automated process to migrate jobs between plugins.


IQ Server Version Hudson/Jenkins 1 Version Compatibility
All versions 2.13 through 2.21

IQ compatibility with Eclipse

IQ Server Version Eclipse Version Compatibility
All versions 2.8 through 2.13

IQ compatibility with Maven

IQ Server Version Maven Compatibility
All versions 2.3 through 2.8
1.45 and higher 2.8.1
1.44 and lower 2.8.1

IQ compatibility with SonarQube

IQ Server Version SonarQube Version Compatibility
All versions 1.0 through 1.2

IQ compatibility with IDEA

IQ Server Version IQ for IDEA Version IDEA Version Compatibility
All versions 2.x and higher 15.x through 2018.x

All versions 1.x 14.x through 15.x

IQ compatibility with Visual Studio

IQ Server Version Visual Studio Version Compatibility
1.32 and higher 1.0
1.31 and lower 1.0